Wikia

WoWWiki

Lua editors/Eclipse (IDE)

Talk0
101,364pages on
this wiki

< Lua editors | Redirected from Eclipse (IDE)

Eclipse is a free software development IDE written in the Java language, but there are versions optimized for Linux, Mac OS X, and Windows. For many, it is becoming the defacto standard, especially for Java and J2ee development. It can also be expanded to provide robust editing for other languages, like Lua, via plugins.

Why Eclipse? Edit

With the development of the right plugins Eclipse could become a powerful editing tool for the AddOn developer. Currently there are two lua plugins for Eclipse, but neither take into account any of the WoW objects/functions. A customized Eclipse editing plugin would need to be authored to accomplish this. The Lua plugins area a great starting point for this.

Ambitious AddOn makers who enjoy using Eclipse could even provide templates for creating .toc files, .xml files, etc.

Where can I get it? Edit

Eclipse can be downloaded here: http://www.eclipse.org.

A Java JDK will be required to operate Eclipse: Java's JDK Download Page

You'll need to choose one of the following Lua plugins:

Lua Development Tools HomePage

LuaEclipse HomePage

LunarEclipse HomePage

Comparison of LuaEclipse and LunarEclipse Edit

As of 11/11/2009 the status of the lua plugins are:

LuaEclipse 1.3.0 (Updated 12/8/2008)

LunarEclipse 1.2.7 (Updated 1/9/2008)

LunarEclipse provides the outline feature whereas LuaEclipse does not. LunarEclipse is also more actively developed than LuaEclipse. For me this was enough to conclude that LunarEclipse is the better plugin for now. --Javek 00:57, 23 January 2008 (UTC)

Installation Notes Edit

LunarEclipse requires the Dynamic Languages Toolkit - Core Frameworks (DLTK), which can be found under Europa Discovery Site->Enabling Features under Find and Install.

Around Wikia's network

Random Wiki