Wikia

WoWWiki

Need Help : 'SetAutoFocus' (a nil value)

101,351pages on
this wiki

Forum page

Forums: Index World of Warcraft Need Help : 'SetAutoFocus' (a nil value)

I work on a addon and i get a error :

Error occured in: Global Message: [string "NoSaveCheck:OnLoad"] line 1:

  attempt to call method 'SetAutoFocus' (a nil value)

Debug:

  [C]: SetAutoFocus()
  [string "*:OnLoad"]:1:
     [string "*:OnLoad"]:1

Its a very old addon that i rewrite I Try this and it works (no more LUA Errors) I delete this Lines (6x) :

     <CheckButton name="NoSaveCheck">
     </CheckButon>

—This unsigned comment is by DaEgo4475 (talkcontribs) 04:10, September 25, 2011. Please sign your posts with ~~~~!

You appear to be using SetAutoFocus wrong, it needs to be passed a boolean. See API EditBox SetAutoFocus. --Gengar orange 22x22Beware the sneaky smile! Fandyllic (talk · contr) 25 Sep 2011 8:11 PM Pacific


Yeah and this is the part i dont understand, i am a noob in LUA sry
and my bad english skills kills me —This unsigned comment is by DaEgo4475 (talkcontribs) 03:28, September 26, 2011. Please sign your posts with ~~~~!
Basically you need to specify either SetAutoFocus( true ) or SetAutoFocus( false ) and not SetAutoFocus(). Without seeing more code, I can't guess at what else might need to be fixed. --Gengar orange 22x22Beware the sneaky smile! Fandyllic (talk · contr) 26 Sep 2011 6:45 PM Pacific
Thx, yeah i found this to, no more error for me now, thx
Is there a really good Tool out there, to find LUA errors with a good tutorial ?
I try LUA Player but it just say the same

Around Wikia's network

Random Wiki