Wikia

WoWWiki

Talk:Searching

101,961pages on
this wiki

Back to page | Redirected from WoWWiki talk:Searching

I get a page with the following error message on it when I search for hibernate. Yet I search for 'druid spell' and the search returns results.--Ehertlein 12:24, 23 Mar 2005 (EST)

A database query syntax error has occurred. This could be because of an illegal search query (see Searching WoWWiki), or it may indicate a bug in the software. The last attempted database query was:
SELECT cur_id,cur_namespace,cur_title,cur_text FROM cur,searchindex WHERE cur_id=si_page AND MATCH(si_title) AGAINST('+hibernate' IN BOOLEAN MODE) AND cur_namespace IN (0,9,11) LIMIT 0, 20
from within function "SearchEngine::showResults". MySQL returned error "1016: Can't open file: 'searchindex.MYI' (errno: 145)".


I know that this is a year later, and I do know that it used to be that way, but now, when I use the function I mentioned on the article page and at Firefox, I got http://www.wowwiki.com/Special:Search?search=druid%20spell. So the internal search is functioning right now. I hope we can get the searched changed back from Google. Schmidt 19:36, 16 April 2006 (EDT)

Just bumping this again, I just testing it and the internal search worked for me as well :) -- Kirkburn 14:35, 13 June 2006 (EDT)
please get the internal search, this google-%&/! is kinda crappy. and... as far as i know the wiki search, you must exactly enter a term that already exists or one of a redirect to NOT come to the article. Lakesire will say 'nothing found' and present some search results, lakeshire will go to the article. sometimes even capitalisation must be right ;) Alliance 15HJT (t/c) 19:08, 18 September 2006 (EDT)

Sorry for being so blunt, but the google search blows chunks. I'm trying to use this to change my default search to the default MediaWiki search, but it isn't really working. It does plant the search box on the left, but when I type something and press enter all it does is bring up the search panel on the right. It's basically equivalent to simply clicking "Search WoWWiki" on the left. It doesn't actually search anything, it just brings up the search page. Am I missing something? --Divisortheory 15:46, 18 September 2007 (UTC)

Updates! Edit

A note about some search updates.

We're now on a new search engine, LuceneSearch, which allows for more Google search-like results with relevance ranking. For example - http://www.wowwiki.com/index.php?title=Special%3ASearch&search=bugs&fulltext=Search

It searches only the main namespace by default (as before), but you can change this from your user preferences. The Monaco search box uses this searching method, but will take you directly to the article if you give it an exact pagename (it is known that this is not perfect behaviour).

I have noted two bugs, which I have reported:

  • Doesn't give namespace options on initial screen, Special:Search
  • The relevance line is hardcoded - meaning I can't change the colour of the green line

If you have more problems/suggestions, please note them below. Kirkburn  talk  contr 20:00, 11 June 2008 (UTC)

If you search, mark a namespace that isn't marked by default then search again by clicking the upper "Search" box (not the one by namespaces), the search will be in the default namespaces. I'm not sure if this is a bug or not, but it's annoying to not realize it after you've done a few searches. User:Gourra/Sig2 20:05, 11 June 2008 (UTC)
I searched for "Clockwork Gnome" i got only results with "clockwork" in them, no gnome in them, not even gnome only results. I reversed it to "Gnome Clockwork" to see if there was a bug with multiple words, same result. Searched for "Gnome" on itself, lots of wonderful results. To me that's a bug. --   14:21, 12 June 2008 (UTC)
"Clockwork Gnome" searches for "Clockwork" AND "Gnome" - and it looks okay to me. You can do "Clockwork OR gnome" to get both and either. Kirkburn  talk  contr 08:59, 17 June 2008 (UTC)
It's changed since i last did my search, but half the bug still persists. "Clockwork Gnome" now results in "clockwork" AND "gnome" results, followed by "clockwork" only results. The latter shouldn't be there in an AND, or "gnome" results should be there too if it's not an AND. Seems to append the one which produces the lowest amount of results only (theory, no testing).
Was also wondering, what happened to the Go and Search buttons? Search now functions as Go, meaning if an exact match is found it will go to that page, where as Search used to still show search results even if there was an exact match. That option has been lost with this new engine, can we get that functionality back? :/ --   16:11, 17 June 2008 (UTC)
Regarding the first bit clockwork gnome gives me results that look fine - I think the reason some of them don't show "gnome" is because they contained on the page in some other fashion (e.g. a template). Not sure though.
For the search buttons, correct, and known. It's partly why I added "Advanced search" to the toolbox. I want the functionality back myself - it's not been forgotten. Kirkburn  talk  contr 16:18, 17 June 2008 (UTC)
If inclusion is causing it, then fair enough. Might look into it more when i have time, but it's not on my priority list atm. Glad to know the other thing is being worked on :) I suspect the Advanced Search and Toolbox are things limited to monaco/quartz though :P --   16:23, 17 June 2008 (UTC)
Oh, sorry. I just tried it with the search string "Tyrande Whisperwind", and it still seems to be functioning as normal though. Kirkburn  talk  contr 16:31, 17 June 2008 (UTC)

Update - the search engine now searches the main, Project, Guild and Server namespaces by default, unless you change your personal preferences. Kirkburn  talk  contr 17:14, 17 June 2008 (UTC)

I am not sure how to get help. I believe the search engine is not functioning correctly. I use it all the time but now it is not returning pages correctly at all. For example. "libram of resilience" only searches on "of" and not the other two words. If I use the Google search it returns the correct pages. This happened with a few of my searches.

Thanks for the report, I'll enquire. Kirkburn  talk  contr 16:39, 21 June 2008 (UTC)

I searched for "escape sequence" and also "escape sequences" and got 5 results, from some undocumented patch changes to "shaman tactics," but no UI Escape Sequences. -- Tuhljin (talk) 20:50, 21 June 2008 (UTC)

I've reindexed that article. --Emil@Wikia (talk) 09:49, 23 July 2008 (UTC)

More updates Edit

I just noticed that the search page has got another update so that it has all the namespace options directly on Special:Search. How do people feel about the results it gives? Kirkburn  talk  contr 18:58, 17 October 2008 (UTC)

Around Wikia's network

Random Wiki